«

»

Print this Post

Configuring a PreSonus Firepod for Pro Audio in Gentoo

For the last 5 years or so, I’ve done all my scratch recordings with an old school PCI M-Audio Delta 4/4, and to be honest, that worked just fine. But since my box doesn’t have much in the way of available PCI slots, I decided to give the PreSonus Firepod a try.

This is how I’ve configured my firepod to work with Ardour.These guys are on to something… the linux audio geeks. Let me tell you JACK is an amazing piece of software. It allows me to route my audio, in or out, to wherever I damn well please.

It’s shameful to admit, that this is the first FireWire product I’ve ever tried, so I really wasn’t sure what to expect under linux. I was pleasantly suprised at how easy it was to configure.

First, I grabbed the freebob drivers from http://freebob.sourceforge.net/index.php/Main_Page

I downloaded the newest stable tar.gz file and unzipped it in a temp directory.

#gzip -d *.gz
#tar -xvf *free*

Then, I changed to the directory and ran the configure script.

#cd *free*
#./configure

On the first try, the configure script complained about missing libraries. Here are the libraries you’ll need to install the FreeBob (FFADO) drivers for a firewire audio interface.

1.) libavc1394
2.) libraw1394
3.) libeic61883

So I emerged those three packages and ran the configure script again. This time, it ran to completion.

Next I compiled the package and installed it.

#make
#make install

And voila, the driver is installed.

I gave jack a quick fire up to test, set the driver to freebob and… damn, it didn’t work. It failed with the error "Driver Freebob Not Found".

So some research later, I found that the JACK ebuild in the portage tree doesn’t make use of the freebob USE flag. Fortunately the package in the pro-audio overlay does. So I had to enable the pro-audio portage overlay.

#layman -fa pro-audio

and then re-emerge JACK
#emerge jack-audio-connection-kit

After it compiled, I fired up qjackctl again and gave it another shot and….. No luck.
Permission Denied.

So, I noted that udev gives permission to /dev/raw1394 like so:
crw-rw—- 1 root video 171, 0 Jul 10 18:39 raw1394

I tried to change the permissions for /dev/raw1394 in /etc/udev/permissions.d as suggested in the freebob documentation, but I had no love. So being as lazy as I am, I just added my user account to the audio group in /etc/group

I rebooted the machine for good luck, even though it’s not required… and when it came back up… So did my firepod.

Not exactly plug and play, but one of the easier devices to configure. I was expecting it to take longer to configure, and work poorly if at all, but it works just fine. Free’s up my PCI slot, and gives me 8 inputs and 8 preamps.

Not bad for $400.

Permanent link to this article: http://www.lukemacneil.com/2007/07/10/configuring-a-presonus-firepod-for-pro-audio-in-gentoo/

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>